3

I am quite new to ArcMap. I want to add a column of a .csv file to the end of the attribute table of a feature class. The column and the attribute table are of the same length. I tried to use the "append" tool. First I copied and pasted the target column of my .csv file into a blank Excel spreadsheet and saved it as a new .csv file. I then added this to ArcMap. When I try to append this to my target attribute table using the "append" tool I get the following error message:

"ERROR 000338: Inputs must be either all Feature Classes, Tables or Rasters; not mixed."

enter image description here

This is confusing because I only have one input dataset, so I'm not sure where the "mixed" warning comes from...

  • 3
    Append adds to the length of a table, not the width. You want to Add Field, Join, and Calculate Field. – Vince Nov 8 '19 at 13:17
  • Aha, thanks for the correction! Could you please elaborate a little on exactly how I carry out the Add Field, Join and Calculate Field steps? Many thanks – Yusef_S Nov 8 '19 at 14:01
1

In the arcmap catalog view navigate to the location of your csv file and drag it into your table of contents.

Right click on the layer you want to join the csv to and click on joins and relates. Join the csv to the feature class and if you want to remove some fields right click the properties of the feature class and choose only the fields you want.

If you want a final dataset that has the fields permanently joined export the table with the join to a new feature class.

| improve this answer | |
  • Thanks for the answer. That was basically what I did, except I removed the columns I didn't want from the csv first before importing it. It just seems like a bit of a clunky way to do a simple task - I would have thought software such as Arc, which seems to have a lot of functionality, would just have an option to add a column from a different table. But if that's the only way then fair enough. Thanks for the info :) – Yusef_S Nov 20 '19 at 12:29
  • No problem if I helped feel free to up vote my answer. Thanks – jport Nov 20 '19 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.