4

The processing toolbox stopped working in the previous QGIS 3 ltr version I had installed. Now installed 3.4.13 but processing toolbox still not working. I've tried changing the GRASS path without success but none of the processing providers algorithms work - SAGA, etc. I have seen that 3.4 version has some issue with GRASS and so tried to use the Osgeo installer. With this a message displays stating that the GRASS module path is wrong. enter image description here

I have checked and it seems to be correct.

enter image description here

I have tried looking at the configurations in the settings/advanced tab as the screen print but not really sure what I am looking for here. enter image description here

I really don't know what else to do. I've installed/reinstalled using both the network installer and standalone installer many times.

QGIS also crashes with the following message

enter image description here

If I add a modified bat file do I need to do anything else?

  • What do you mean by "stopped working"? Does QGIS crash when you try to open the toolbox? Is the button grayed out? – csk Nov 8 '19 at 21:01
  • For example I click on r.reclass and the toolbars across the top grey out momentarily and then nothing else happens – Sean Jarrett Nov 9 '19 at 7:36
  • 2
    Try to use clean fresh profile. – GSienko Nov 9 '19 at 11:21
  • Can you elaborate on that please - is that a setting in QGIS? – Sean Jarrett Nov 9 '19 at 15:50
  • I can't interpret the crash included in your latest update. About to how to start with a clean profile, navigate to C:\Users\Your-User\AppData\Local and Roaming folders, and delete the QGIS folders in them. – Gabriel De Luca Nov 10 '19 at 20:56
3

I think I had that problem before.

I use the OSGeo4W 64-bit version. I try to keep the latest stable and long-term release versions of QGIS updated.

In one of the updates, GRASS happened to have version 78 instead of 76, but the file that raised QGIS still referred to the previous folder.

I have the C:\OSGeo4W64\bin\qgis-ltr.bat file with the following content:

@echo off
call "%~dp0\o4w_env.bat"
call "%OSGEO4W_ROOT%\apps\grass\grass78\etc\env.bat"
call qt5_env.bat
call py3_env.bat
@echo off
path %OSGEO4W_ROOT%\apps\qgis-ltr\bin;%OSGEO4W_ROOT%\apps\grass\grass78\lib;%OSGEO4W_ROOT%\apps\grass\grass78\bin;%PATH%
set QGIS_PREFIX_PATH=%OSGEO4W_ROOT:\=/%/apps/qgis-ltr
set GDAL_FILENAME_IS_UTF8=YES
rem Set VSI cache to be used as buffer, see #6448
set VSI_CACHE=TRUE
set VSI_CACHE_SIZE=1000000
set QT_PLUGIN_PATH=%OSGEO4W_ROOT%\apps\qgis-ltr\qtplugins;%OSGEO4W_ROOT%\apps\qt5\plugins
start "QGIS" /B "%OSGEO4W_ROOT%\bin\qgis-ltr-bin.exe" %*

I have the idea of having modified it by hand one day, replacing all the grass76 chains withgrass78.

Now I run that file to run QGIS, which recognizes the PATH without problems.


If your qgis-ltr.bat doesn't have the grass call and path lines, make sure that you have a ...\apps\grass\grass78 folder, copy that lines from this answer to a new qgis-ltr_modified.bat file, to preserve the original, and try running QGIS from it.

  • I cleaned my profile and today installed 3.4.13 & GRASS 7.8.1 using OSGeo4W and all seems to be working – Sean Jarrett Nov 15 '19 at 8:59
  • Good to know it! Was an update last days to the current qgis-ltr 3.4.13-2. It is likely that the problem has been solved from there. I hope you find the OSGeo4W update system as good as I see it. Successes! – Gabriel De Luca Nov 15 '19 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.