2

I frequently use QGIS to digitize satellite imagery or georeferenced maps. Recently, however, the Add Polygon Features and Add Line Features have stopped working - I can Add a Polygon Feature and trace the polygon, but QGIS will not respond to my right click which should finalize the trace and initialize the polygon feature.

Right-clicking (using control + , as this is a Macbook OS 10.13.6) works fine for other operations in QGIS, such as right clicking on a Layer to export, etc.

I have tried QGIS versions 3.4, 3.8, 3.10. And I have used every conceivable keyboard shortcut to see if it would register as a right click (command click, shift click, . click, etc). I have tried to find a way to change how QGIS interprets the keyboard, but I haven't found anything.

What's more, after trying long enough to 'close' the polygon, QGIS stops responding to the Esc key to exit polygon creation mode.

If anyone has encountered this issue, how did you resolve it?

  • That sounds like a terrible bug. I suggest making a bug report, and hopefully it will be resolved soon. An awkward workaround would be to digitize the vertices in a temporary point layer with an auto-incrementing field, then use points to path to turn them into lines, then use the vertex editor (with snapping) to make the line a closed loop, then use lines to polygons to turn it into a polygon. If you can find a non-manual way to convert the line into a loop, you could put the whole process into a graphic modeler. – csk Nov 12 '19 at 19:58
  • I have the same issue and have not found a solution. Would love help with this. – Rip Langford Nov 14 '19 at 19:48
2

Thank you @csk, I'll try to find time file a bug report.

I found a solution that's new to me as a longtime Macbook user - it turns out that on Macs a two-finger click on the trackpad registers as a right-click, and QGIS still recognizes this for digitizing. Regardless, this should be fixed, as I don't think many people know about that.. Hope this works for you @RipLangford

| improve this answer | |
2

If you have an Apple Magic Mouse, you can go to System Preferences>Mouse. Check the box to enable secondary click. Select 'Click on the right side'. Then in QGIS, you close the polygon by clicking on the right side of the Magic Mouse. Finally, your line will be saved into your Shapefile.

The bug in QGIS 3.12, is that it does not observe control-clicking as a right click when Apple Human Interface guidelines mandate that it should.

This is a good tutorial for the rest of the steps of saving a line to a shapefile: https://www.youtube.com/watch?v=YDRjc3X3FJk

Update: If you want more control over your mouse, and you have OS X 10.14 or older, look into JiTouch which offers the option to have a left, middle, and right mouse button on an Apple Magic Mouse or trackpad. I tried MagicPrefs, an alternative mouse hack, and it didn't work reliably. JiTouch has worked much better but not quite perfectly.

| improve this answer | |
0

I had an identical problem with QGIS 3.12 on a PC before discovering it was the Features Attribute pop-up that had moved almost totally off the bottom of the screen, not allowing an id to be input to finalise the procedure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.