5

I am using QGIS 3.8 and I am using a layer from OSM of Tokyo city. The layer is consisted from many polygons and I have tried to merge it but I got error. This is how the original layer was look like: enter image description here

This is the parts I manage to merge: enter image description here

When I have checked the geometry validity no error appeard on the problematic areas, beside this one that appeard on area that I manage to merge. I have tried to check but couldn't find any visible error:

enter image description here

I really don't know how to fix it and how to merge the "green layers" with the pink ones. I have seen previous messages in this forum but they were using scripts.

any idea ?

6
  • What error did you get? Commented Nov 12, 2019 at 11:10
  • Holes lies outside shell
    – ReutKeller
    Commented Nov 12, 2019 at 12:51
  • Which tool are you using? Try to use Dissolve (Native and from GDAL) and Polygon dissolve from SAGA. Commented Nov 12, 2019 at 13:34
  • If you do not have a real topology error in your data you may suffer from an issue that is fixed lately. lists.osgeo.org/pipermail/gdal-dev/2019-October/050967.html. Unfortunately the fix is at the moment only in GDAL-master and you must either build GDAL yourself or download a ready made development version.
    – user30184
    Commented Nov 12, 2019 at 15:22
  • 1
    Can you share the file? This way it would be possible to see if there are other ways to solve the problem
    – Babel
    Commented Nov 14, 2019 at 9:37

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.