2

I was trying to merge 2 DEM raster using QGIS raster - merge.

Is there any way to not add nodata to the merged raster?

enter image description here

enter image description here

3
  • 2
    Please include in the question some details, like with what tool you want to do it. You are asking about any way to not add nodata; so, how are you merging them in a way that nodata is being added? Commented Nov 13, 2019 at 0:50
  • 2
    As @GabrielDeLuca says, what software are you using? precisely what steps have you tried? What are the NoData values for your inputs and output? Is the (apparent) sea set to the NoData value and all you need to do is set the NoData value in the output? Commented Nov 13, 2019 at 1:03
  • 1
    You can try including, in the Additional command-line parameters [optional] field, the -a_nodata none parameter. Commented Nov 14, 2019 at 1:34

2 Answers 2

3

Updated answer: QGIS version 3.22.0

You can use the merge function raster -> miscellaneous -> merge. Then, make sure that you specify the no data value for your input raster and for the output raster. For my case, -9999 was the no data value from the input raster.

Merge function

You can get this information from the properties section of the raster.

raster info

1

Yes, make sure not to check the box next to "No data value".

enter image description here

3
  • when untick the "No data value" I still get the result as the second figure in the question. PS. I assume you are using an older version of QGIS? Cause in the latest version (v3.8.3) you can't uncheck the box
    – Roy
    Commented Nov 18, 2019 at 22:50
  • @Roy What is your ultimate objective? The merged output will always have at least the minimum bounding area composed of pixels (i.e. you can either display the pixel values or "hide" them as NoData).
    – Aaron
    Commented Nov 19, 2019 at 4:15
  • Thank you Aaron. I want to cut cross-section form the merged DEM.
    – Roy
    Commented Nov 20, 2019 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.