I am looking to project all my data into EPSG::2959 (NAD83 CSRS UTM 18N) as I am working out of Ontario, Canada. Every time I start a project I set the project CRS to EPSG:2959, and then begin to add data. I typically use OSM from "QuickMapServices" (QGIS plugin) as a basemap for all projects, and change the CRS of OSM to EPSG:2959.

At this point I begin adding data, which typically changes the project CRS to EPSG::3857 or EPSG::4326. I typically change the CRS of both the project (again) and layers at this point. I often 'Save As' the data to the correct projection.

My issue now comes when I use the measure tool after everything is in EPSG::2959 (NAD83 CSRS UTM 18N). The distance measured is always incorrect.

How can I fix this to accurately measure distances in EPSG::2959?

I will take any advice or change any steps in order to fix this issue.

This may have been asked before but it's causing me an incredible amount of trouble and I can't seem to find a solution.

  • 1
    don't use an OSM base map if you want to control the project projection.
    – Ian Turton
    Commented Nov 18, 2019 at 15:53
  • Even if the CRS is changed for the OSM base map?
    – Paul
    Commented Nov 18, 2019 at 15:59
  • 1
    Don't change the CRS of the basemap. Change the CRS of the project.
    – csk
    Commented Nov 18, 2019 at 18:04
  • This actually did help me, thank you very much! I haven't tested it yet (aside from opening it up with a project CRS of 2959 and OSM at default) but it makes sense that this is the problem!
    – Paul
    Commented Nov 18, 2019 at 18:23

1 Answer 1


enter image description here
Make sure you have disabled the setting in QMS to force OTF projection, and then set your project properties accordingly.

Map rendering performance will degrade a bit (at least until reprojected tiles are cached), but it is totally worthwhile to work this way.

See? Not a problem anymore: enter image description here

  • OTF projecting is turned off by default, and so this doesn't seem to be the issue unless there is more to this?
    – Paul
    Commented Nov 18, 2019 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.