0

I have QGIS on 2 different standalone PC and I share/sync files between them. I now need my second PC QGIS to work with a file that includes PostgreSQL queries. PC 1 is original PC and all is well there. Various versions of QGIS and all deployed versions of postgres/postgis behave as expected. All hosted on standalone PC (localhost) PC 2 - QGIS works fine, I have created an identical Postgresql database including GIS extensions, name, credentials etc and populated this with identical underlying data. QGIS can connect and query this database.

Issue: If I then open one of my sync'd QGIS files on PC 2 it fails to connect/open any vectors linked to the PostgreSQL database. I've tried to troubleshoot/google, used various V3 QGIS and failed to resolve this. Same file opens fine on PC 1. On the face of it I can see no reason this won't work - however need some expert opinion/advice.

7
  • Are there any error messages? Are you connecting with the same credentials for both PCs? What kind of files are you trying to open? Are they queries or QGIS saved documents? Nov 25, 2019 at 0:19
  • 2
    Have you considered not duplicating the postgres database, but instead sharing it over your local network? Nov 25, 2019 at 0:20
  • @MichaelStimson my files are QGIS project files, that contain a variety of vectors and associated map data. I believe the postgres credentials are identical, as whne i added the postgres database to the browser it worked with same credentials, same port, same name, same tables. The vector layers that fail to open and are exceptioned when project file is opened - all failed pull data from postgis, using queries that was originally built using the DB manager.
    – Melbnz
    Nov 26, 2019 at 7:23
  • @alphabetasoup my pc are standalone laptops and i require them to work independently offline - but appreciate the suggestion :-)
    – Melbnz
    Nov 26, 2019 at 7:24
  • I will try and replicate some of my queries on PC2 to see if the fundamental postgres query process works - thanks for your questions Michael.
    – Melbnz
    Nov 26, 2019 at 7:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.