1

I'm having some troubles getting wmts service to work. This is what I have done so far:

  1. I have imported OpenStreet Map info for Spain using osm2pgsql into a postgis database. I get Spain info from Geofabrik
  2. I have published planet_osm_line with this bounds:enter image description here
  3. I have enabled tile caching in the layer, with this config: enter image description here

Then from layer preview menu, I can see values with no problem using open layer. You can check here

However, from tiles cached menu, if I try to open EPSG 900913 view, only errors are thrown in the chrome console, with an out of bounds message. You can check it here enter image description here

    <ExceptionReport version="1.1.0" xmlns="http://www.opengis.net/ows/1.1"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.opengis.net/ows/1.1 http://geowebcache.org/schema/ows/1.1.0/owsExceptionReport.xsd">
  <Exception exceptionCode="TileOutOfRange" locator="TILEROW">
    <ExceptionText>Row 131073 is out of range, min: 131071 max:131072</ExceptionText>
  </Exception>
</ExceptionReport>

Any ideas of whats going on? Why WMS service works and WMTS do not? What have I to configure to get it work?

2

Your data has a bounding box of -180,-90,180,90 so is almost certainly not in EPSG:3857 (unless it is a small survey of part of Null Island), thus you have lied to GeoServer and it gets confused. WMTS is less forgiving that WMS about this sort of thing. I would however, expect that your WMS image is mostly blank.

Update

You have set the native extent of your data to -180, -90, 180, 90 which is a very small patch of Null Island if your data really is in EPSG:3578. Click on the calculate bounds from data and you will see some sensible numbers in that box. You can then use calculate from native bounds in the lat/lon bounding box and will see sensible numbers in that.

You have also changed the bounds of the tile set (which is why WMTS is not working properly) - most systems rely on these bounds being set to the whole of the world (otherwise zoom levels will be wrong).

Also you should always change the password on any publicly available GeoServer instance.

| improve this answer | |
  • It's a bit confusing then why planet_osm_roads works with that boundix box and not planet_osm_lines, because roads is a subset of lines. Whatever, i have tried both option calc from data and compute from srs bounds. Both with the same result, wms works, but wmts don't. As far as i know, data from open street map is in EGPS 3857. – Rumpelstinsk Dec 2 '19 at 6:25
  • With out seeing the actual data it is hard to say, however if you set it as epsg:4326 does it work? – Ian Turton Dec 2 '19 at 8:26
  • If I set srs to 4326 in the layer config, it does not work either. I tried all the option in the SRS select: maintain, force, reproyect, with the bounds from SRS and from the data. WMS does not return any data. http://ec2-34-242-255-134.eu-west-1.compute.amazonaws.com:8080/geoserver/AWS.Qatium/wms?service=WMS&version=1.1.0&request=GetMap&layers=AWS.Qatium%3Aplanet_osm_line&bbox=-180.0%2C-90.0%2C180.0%2C90.0&width=768&height=384&srs=EPSG%3A4326&format=application/openlayers. Despite the layer config, if i change srs to 3857 in the url it works. So it seems 3857 it's the correct SRS – Rumpelstinsk Dec 2 '19 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.