1

We have ArcGIS Online configured for "enterprise" logins to authenticate against our MS Active Directory. I can add users from AD by sending them invitations in ArcGIS Online. They must respond to these emailed invitations for their account to be created in ArcGIS Online.

I would like to add AD users using the option, "Add members using their enterprise ID without sending invitations". This gets their account set up immediately, and then I can add them to groups, etc, without waiting for them to respond to an invitation.

However, to use this option, I have to include the user's "Enterprise ID".

What is this Enterprise ID, and how do I find out what a particular user's Enterprise ID is? Is it something I have to get from Active Directory? If so, how do I find it for various users?

(I have tried various combinations of username, email address, and organisation name and underscores, but with no luck.)

UPDATE

As per comments, I have now tried populating the "Enterprise ID" field using the format, DOMAIN\user.name (and DOMAIN/user.name), but it will not accept anything with either a \ or a / in it (no error, but the "Next" button does nothing). As soon as I remove the (back)slash, the "Next" button works as expected (but the account does not work because I don't know what I'm supposed to put in the "Enterprise ID" field.

I note that the examples in ESRI's documentation do not use this format. The examples there are "jonc1111" and "sati3554". See: https://doc.arcgis.com/en/arcgis-online/administer/invite-users.htm#ESRI_SECTION1_D4222EB63EF14C96BF37F1A098F37AFA

I feel like there's something very simple/obvious that I'm missing, like I'm looking at the problem through the wrong lens or something. I just can't figure out what I'm sure is supposed to be straightforward.

  • The enterprise ID must match the member's existing enterprise credentials.. doc.arcgis.com/en/arcgis-online/administer/… – Mapperz Nov 30 '19 at 3:53
  • Yes I’ve read that. But what IS the Enterprise ID. How do I know what value to use for the Enterprise ID? It doesn’t appear to work if I use the email address nor if I use the username portion of their email address. So what actually should it be and how do I find it using AD? Treat me as completely ignorant of AD. – Son of a Beach Nov 30 '19 at 4:16
  • ours is like ad/username (area51/snoopy) username is the same windows login. our AD login is tided to email as well. – Mapperz Nov 30 '19 at 15:19
  • Unfortunately it will not allow me to use either a slash or a backslash in the Enterprise ID field. No error, just nothing happens if I hit the “Next” button. Delete the (back)slash and then the Next button works. – Son of a Beach Dec 1 '19 at 9:56
0

ESRI have responded to me on this issue. They have said that the Enterprise ID varies according to how your directory service has been configured. You have to interrogate your directory service configuration (in our case Active Directory) to find out the Enterprise ID format/values.

Before I got around to trying this out, I went through the motions of trying values that I am 100% sure I tried before. This time it WORKED for the username part of the email address - ie, everything before the "@".

I'm sure I tried this multiple times previously and it failed. But it's worked for two users now.

UPDATE

I have just added a few more users using the username part of their email addresses (ie, before the "@") for their enterprise ID and it has FAILED for them again! Ie, it successfully creates an account, but they cannot login with that account.

So I had to revert to using the method where it sends them an email that they need to confirm to create their account.

I have noticed that for the users (or the times?) when this method creates accounts that don't work, it creates the username with the format: user.name_CompanyName

When it succeeds, it creates the username with the format: user.name@domain.name_CompanyName (even when excluding the "@" and everything beyond it from their enterprise ID)

ie, a completely different format of username

FURTHER UPDATE

For those accounts for whom this didn't work, I have now created some new accounts using the full email addresses (including the "@domain.name") as the enterprise ID and this worked!

So it appears that some times (or for some accounts), I have to use the full email address, and for other times (or other accounts) I have to use only the username part of the email address (before the "@"!

This inconsistency is going to drive me nuts! Is this due to changes in Active Directory over time? Changes in ArcGIS Online over time? Or differences in how some accounts are configured in AD?

I assume (and hope!) the latter, but how do I interrogate AD to determine which enterprise ID format to use for which accounts?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.