0

Recently I updated my development virtual machine (VirtualBox) from Debian 9 to Debian 10. Except for a few minor bumps along the road, everything went smooth. But when I try to run QT Designer I got this message in terminal (in Czech environment):

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Neoprávněný přístup do paměti (SIGSEGV)

and this in syslog:

kernel: [403847.205496] designer[7998]: segfault at 8 ip 00007f9977eef510 sp 00007fff537da728 error 4 in libQt5Core.so.5.11.3[7f9977cdd000+2a4000]
kernel: [403847.205502] Code: e9 8b 2e e0 ff e9 d4 2e e0 ff 48 8b 4f 08 83 e6 01 01 f6 0f b6 51 20 89 d0 83 e2 fd d0

QT tools came from the system repository as a dependency for the qgis package. After a bit of fiddling around (without success) I try to create a completely fresh virtual machine, but with the same results. I also try different VirtualBox VGA settings, but also without luck.

There is more info about the system

  • Virtualization: oracle (VBox 6.0.14 r133895 (Qt5.6.2))
  • Operating System: Debian GNU/Linux 10 (buster)
  • Kernel: Linux 4.19.0-6-amd64
  • Architecture: x86-64
  • QT Designer 5.11.3

Any sugestions what is wrong?


EDIT

When QT Creator is installed from QT official site through their online installer, then an integrated designer works fine. When I install Creator through Debian repository (sudo apt-get install qttools5-dev-tools), then the Creator crashes when I try to open UI file inside it.


EDIT 2 It looks like the source of this error is the QGIS plugin for QT Designer. After removing libqgis_* files from plugins folder inside Designer installation, the error disappears...

Reported here as QGIS bug...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.