0

I'm very new to using ogr2ogr so I hope I've provided enough detail to my problem. It's worked in the past.

I'm trying to retrieve GIS data from a WFS feed and saving it into SQL using the following command line.

ogr2ogr -overwrite -f MSSQLSpatial "MSSQL:server=xxx;database=xxxx;uid=xxx;pwd=xxxx" -nln "GardenEquipmentGISData" -nlt MULTIPOLYGON -t_srs "EPSG:4326" WFS:"WFS LINK"

However i get the following error: ERROR 1: Got MULTIPOLYGON geometry as polygonMember instead of MULTIPOLYGON

Note: I've tried -nlt PROMOTE_TO_MULTI because the documentation in OGR2OGR Documentation states that PROMOTE_TO_MULTI can be used to automatically promote layers that mix polygon or multipolygons to multipolygons however it has given me the same error as well.

I have no idea what this error means because the error doesn't make sense to me. I can confirm that the Geo Type from the WFS feed is a combination of MultiPolygon and Polygon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.