1

In QGIS 2.18.22 I have to different vector-shapefiles and I would like to clip the overlay.

Unfortunately, the shapefiles did originally not have the same CRS so I saved them in the desired CRS (EPSG:4326, WGS 84). After that, I opened a completely new project (EPSG:4326, WGS 84) and opened the new shapefiles (OTF is turned off).

However, there is still no overlap between both shapefiles, but I can zoom to each of the shapefiles individually. Clipping is of course still not working.

Do you have any ideas on how to solve that problem? I checked the similar questions but I did not find any solution for my problem.

  • 1
    One (or both) of your shapefiles is not saved as EPSG:4326 - look at the coordinates when you are zoomed in to each layer one of them will not be between -180 - 180, -90, 90 that is the wrong one. – Ian Turton Dec 6 '19 at 14:50
  • Do you mean the coordinate field at the bottom margin next to the scale? Do I then simply have to save it again? – user154760 Dec 6 '19 at 15:21
  • Yes I mean those coordinates, no - you need to go back to the start with that file and fix it – Ian Turton Dec 6 '19 at 15:39
  • You are right - that was the problem. Thanks!! – user154760 Dec 6 '19 at 16:02