3

I have a persistent problem I can't seem to fix. I'm trying to run Count points in polygon. I keep getting this error:

Feature (747) has invalid geometry. Please fix the geometry or change the Processing setting to the "Ignore invalid input features" option. Execution failed after 30.86 seconds

enter image description here

I've run the multipart to singlepart tool, and the Check Geometry tool now comes back with no errors. Same for the Check Validity tool, with both GEOS and QGIS options. And I tried to use the Fix Geometries tool. But I'm still getting the error when I go to do the Count Points in Polygon.

Here is a link to the point and polygon files: https://www.dropbox.com/sh/vz0ap75tab09tht/AAAUxjhR3oWZ8tUxRLclwMbPa?dl=0

3
  • 2
    search for problems in polygons id=355 and id=748, geotechnical processing is a work, analysis, search and correction :-)... – Cyril Mikhalchenko Dec 6 '19 at 19:15
  • The problem seems to be occurring in the point layer. At least according to the errors. Do you see something in the polygon layer that could be throwing things off? If so, I'm happy to check that as you suggested....Or maybe I made that assumption incorrectly. Looking at the polygons now... – Sami Hammer Dec 6 '19 at 20:40
  • 1
    Ah, the polygon layer was indeed the problem! Fixed some holes, and now it all works just fine. Thank you for making me go back and realize where I made the wrong assumption. – Sami Hammer Dec 6 '19 at 21:42
0

Ah, the polygon layer was indeed the problem! Fixed some holes, and now it all works just fine. Thank you for making me go back and realize where I made the wrong assumption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.