3

I'm completely new to GIS field and here what I'm trying to do:

I want to make the QField App connects to internal server which has a PostgreSQL and PostGIS running on it.

  1. I created a schema in PostgreSQL with one geometry type.

  2. I enabled the PostGIS to the database

  3. I created a QGIS project, and added the OpenStreetMap as a layer.

  4. I also used Add layer and chose PostGIS and select my schema (from PostgreSQL)

  5. Also, tried to export the project with QfieldSync

Also, I changed the IPv4 in pg_hba.conf and set firewall rules for PostgreSQL port(5432).

When I use QGis to select points, everything works fine and all data stored to my database. However, when I copy the project to my android phone and use QField, it crashes once I select the project without showing any error.

Is there a special way to export the project to fit with QField?

If I use shapeFiles as layer, the QField works just fine and store data locally but it is not what I need.

  • It says that ssl support for PostGIS is not yet enabled here. You would have to disable ssl, so maybe you'll have to create an intermediate layer that you can script to copy to your postgis on a regular interval. – jbalk Dec 19 '19 at 18:53
  • Thank you, I already solve it after a day of struggling. I will post it – SHADOW.NET Dec 19 '19 at 19:12
2

After a day of struggling, I found part of the solution here

which is basically just altering the pg_hba.conf file and adding server IP with /24

The other part was removing the password from the configuration of the project and just checking the Store option

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.