0

I am having trouble matching up the shapefile Annex downloaded from the City of Bellevue, WA GIS page and the Google satellite imagery loaded as an XYZ Tile layer from the URL https://mt1.google.com/vt/lyrs=s&x={x}&y={y}&z={z}.

The Annex shapefile shows up in Africa somewhere when it should be showing up in the Pacific North West in Washington State. I have set the CRS for the project to WGS 84 EPSG 4326. I have also set the aerial and the shapefile layer CRS to the same WGS 84 EPSG 4326.

Can someone try this and see what is going on here?

3
  • Your base map is probably in epsg:3857 not 4326 – Ian Turton Dec 20 '19 at 20:21
  • I have tried to put both layers & project on epsg 3857 as well and there is still the same issue... – Bryan Dec 21 '19 at 2:51
  • only one is wrong so why try to change both? – Ian Turton Dec 21 '19 at 10:05
3

First of all, don't just set the CRS of a layer.

If you want to change the CRS of a layer, you should re-project it. The actual steps to reproject a layer depend on your GIS software. However: before re-projecting a layer, that layer should already be in its native CRS. See below.

Usually when you load a layer into a GIS software, the layer comes with the CRS already set. If it doesn't, you have to figure out what the native CRS of that data is, and manually set it to that CRS.

The Google satellite layer is probably in EPSG:3857 (Web Pseudomercator). That's the normal CRS for Google maps layers. Open the layer properties and change the CRS to EPSG:3857.

If you changed the CRS of the layer from the city website, remove it from your project and add it back in. If you're lucky, it will automatically load in its native CRS. If it doesn't you'll have to figure out what its native CRS is and set it manually. Or you can try re-downloading it and see if it loads with the correct CRS (just in case you accidentally changed the default CRS for that file).

The city website should tell you what CRS their layers are in. I don't see that information on the page you linked, so you may need to dig around on their website, and possibly reach out to them through the contact information.

While waiting for them to respond, try putting the layer in every available Washington state plane CRS. Then try the UTM projections for the correct UTM zone. Then try as many more different options as you have the patience for. (Stop experimenting when you find the one that makes the layer line up correctly with the basemap.)

2
  • did you try to download the data referenced in the question? – DPSSpatial_BoycottingGISSE Dec 20 '19 at 21:41
  • Perfect I went through the list of all the washington CRS' and tried them one by one and found that the epsg 2285 worked! Thanks for the tip! – Bryan Dec 21 '19 at 3:28
2

I tried this in versions 3.8 and 3.10 and it works just fine.

The shapefile coordinate system isn't ideal (not sure what the spatial reference is- it comes in as 100032, which is generic).

However, any combination of spatial reference, either from the SHP, the basemap, or WGS84/4326 displays the SHP correctly.

My advice would be to start a fresh QGIS project, add the SHP, then add some other known data before adding the Google Maps layer.

As was mentioned, overriding the coordinate system at the QGIS layer level isn't recommended, or necessary in this case.

However, once you get the SHP aligned correctly, definitely export the shp to a new file with a better coordinate system (state plane washington?) and use that instead.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.