0

I am making GET requests against a wfs service specifying version 2.0, when I do not specify an outputformat in the request it returns a body using the schema namespace for wfs 2.0 (wfs:), when I specify outputformat=GML3 it returns a body using schema namespace for wfs 1.1.0 (gml:)

I know that in the get capabilities it states that it supports gml3.2, gml3, gml2 and that these are largely associated with wfs 2, 1.1 and 1 respectively but I was wondering whether the use of a previous wfs version schema in return body was expected behaviour in this scenario as I wasn't expecting it and I can't find any real info on this.

  • I believe that the server is GeoServer and it behaves just that way. I do not know if it is right or wrong. – user30184 Jan 8 at 10:15
  • WFS has no concept of REST, please include the full requests you are making – Ian Turton Jan 8 at 10:56
  • @IanTurton so the request are being made against an arcgis server and is a GET REST request in KVP format; obviously can't include the whole server url but the query params are ?service=wfs&version=2.0.0&request=GetFeature&outputformat=GML3&typenames=TopographicPoint – MDMeany Jan 8 at 13:30
  • It is NOT a REST request - it is a KVP WFS request, what happens if you try with POST and an XML file? – Ian Turton Jan 8 at 14:01
  • @IanTurton ok...it is a WFS KVP request, it's being made against an arcgis server rest endpoint so just assumed it was a REST request, apologies. POST produces same results. – MDMeany Jan 8 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.