0

When first I run GRASS GIS 7.6.0, there is an error message :

(gis_set.py:4772): Gtk-WARNING **: 16:05:43.648: Theme parsing error: 
gtk.css:2:33: Failed to import: Error opening file 
/home/mega/.config/gtk-3.0/whisker-tweak.css: No such file or directory

I ignore the message. I start GRASS GIS. I import raster and vector. I add raster as RGB.

Image is displayed in map display window. Then I choose Imagery > classify image > Interactive input for supervised classification. Then GRASS GIS supervised classification tool appear. But, no image in training area display and preview display. Then I import training area from vector map.

Suddenly, all window GRASS GIS quit except GRASS GIS terminal window.

So, how to solve this problem? I run in MX Linux 19.

8
  • Could you update to GRASS GIS 7.8? It comes with 730 improvements compared to GRASS GIS 7.6: trac.osgeo.org/grass/wiki/Release/7.8.0-News (meanwhile, 7.8.2 has been published).
    – markusN
    Commented Jan 10, 2020 at 20:42
  • Default GRASS GIS in MX 19 is 7.6.0. I don't want my system broken Commented Jan 11, 2020 at 2:29
  • Now, I have cleaned install MX 19. Now no Gtk warning. But, still same. Window GRASS quit after I import shapefile. Commented Jan 11, 2020 at 6:43
  • Do you use the wxGUI itself or launch v.import on command line? If the former, please try the latter.
    – markusN
    Commented Jan 11, 2020 at 10:42
  • ScreenToClient cannot work when toplevel window is not shown. G__open(read): Unable to open '/home/mega/grass2/PERMANENT/. tmp/mega/vector/trAreas55950/frmt': No such file or directory. That is the message. Commented Jan 12, 2020 at 2:42

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.