1

This may have a very simple answer but I can't find it.

I have a print composer template saved, but when I open it in a new project I can't see a way to get the map to update to the new project. It just stays blank. Is there something like the legend where you can auto-update it or link it to the current project or do I need to add the map in manually every time?

  • The compositions are saved by project. If you create a new project you will not have the compositions saved in other – Fran Raga Jan 9 at 12:00
  • But I can open a new print composer and import a previously created template. It seems to defeat the purpose if I need to add a new map each time instead of just linking it to the current project somehow. – Dugz Jan 9 at 12:38
  • With python you can do with a macro. From the interface I don't think you can – Fran Raga Jan 9 at 12:55
  • If the layout that you saved as a template had a map in it, then when you load the template into a new project it should have a map in it. But you might need to manually set the extent of the map. And if the original map item didn't have a border, and it loads as a blank map, it will be invisible in the layout until you select it. Use the Items Panel to find it. – csk Jan 9 at 17:05
0

May be I didn't understand all your expectations, but you can check this :

How to import a Composer Template into QGIS Print Composer?

In addition for your problematic about auto-updating the legend, yes there a way :

https://docs.qgis.org/3.4/en/docs/user_manual/print_composer/composer_items/composer_legend.html#legend-items

In your legend option, you have to check the option of auto update and filtering the entities of your legend with the funnel.

|improve this answer|||||
0

I assume you're missing the button shown in the image below. You can find it in by clicking your map and navigating to item properties dialog. There in the uppermost row you can find a set of buttons with which to alter map extent. The button you're looking for is called Set Map Extent to Match Main Canvas Extent. This of course is a manual solution and it requires you to have the extent you wish for in your main canvas.

Please note that I don't unfortunately have the newest QGIS 3.10.x installed on this computer so the screenshot below was taken with QGIS 3.6 and thus some changes might have occurred.

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.