1

I am trying to create a PostGIS extension in pgAdmin4.

When typing CREATE EXTENSION postgis;, or through "db_name > Create > Extension > General > Name = postgis", I get this error:

ERROR: could not load library "C:/Program Files/PostgreSQL/12/lib/postgis-2.5.dll": The specified procedure could not be found.

What I have done so far:

1) I've checked this question that addressed the same issue, and moved the two .dlls ("libeay32.dll" and "ssleay32.dll"), as suggested, but the error remains.

2) I have verified that "libxml2-2.dll" is in the bin folder.

3) I've restarted pgAdmin4 but didn't help as well.

Does anyone have any suggestion?

Version: PostgreSQL 12.1, compiled by Visual C++ build 1914, 64-bit / PostGIS 2.5.3

2

Try to reinstall PostGIS by the following executable on this page : http://download.osgeo.org/postgis/windows/pg12/

The download will allow you to get the necessary dll files. When PgAdmin4 was released, when you installed PostGIS with StackBuilder, some files were missing. They updated the executable a few days later and the problem was solved.

| improve this answer | |
  • This worked perfectly, thanks!! – mtao Jan 13 at 13:08
  • You're welcome ! – Vincent Bré Jan 13 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.