1

A few weeks ago I formatted my laptop where among other things QGIS 3.4 was installed.

In the last 48 hours I was busy trying to reinstall it, but until now without succeess. I have a Thinkpad with Windows 10 PRO. I installed versions 3.4 and 3.2 several times: everything goes well but I do not get the launch icon and in "ProgramFiles" the postinstall.bat icon gives the message:

Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.

With a Windows technician I have checked all the admin settings in my PC. We also have created an administrative account. Same issue.

Edit: I have installed using OSGEO4W. It was installed not only QGIS 3.10 but also a lot of software which I would like to get rid of. When I open QGIS I ge this message: ' An error has occurred while executing Python code:

*PermissionError: [WinError 5] Access is denied Traceback (most recent call last): File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\algs\saga\SagaAlgorithmProvider.py", line 86, in loadAlgorithms version = SagaUtils.getInstalledVersion(True) File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\algs\saga\SagaUtils.py", line 141, in getInstalledVersion universal_newlines=True, File "C:\OSGEO4~1\apps\Python37\lib\subprocess.py", line 756, in init restore_signals, start_new_session) File "C:\OSGEO4~1\apps\Python37\lib\subprocess.py", line 1155, in _execute_child startupinfo) PermissionError: [WinError 5] Access is denied

  • 1
    You do not have permissions to the file or the file location., check this support.microsoft.com/en-us/help/2669244/… – Fran Raga Jan 14 at 8:19
  • This was checked by the Windows Technician, seems to be in the right place. – high_point Jan 14 at 8:24
  • 1
    Did you use an administrator type account when you installed QGIS? – GreyHippo Jan 14 at 20:53
  • Yes my account is administrator. – high_point Jan 25 at 10:45
1
  • Check your antivirus. In my knowledge, Kaspersky has already classified QGIS as a Trojan in the past on our network when using the Osgeo4W installer.
  • Try the .exe rather than the Osgeo4W installer if it's the case.
| improve this answer | |
  • I do not have antivirus, Windows 10 has some functionality builted in. I have installed until now the -Standalone installers from OSGeo4W packages- – high_point Jan 14 at 9:59
  • I have installed using OSGEO4W. – high_point Jan 14 at 13:42
  • Have a try with the standalone installer and see if it goes through – gisnside Jan 15 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.