I have a default Python installation in c:\Python27. I have also installed Python through the OSGeo4W installer, which has created a "sandboxed" Python installation with all the geospatial bindings I need. Now, I need to package a script using py2exe, but I can't figure out how to install or configure py2exe to work with the OSGeo4W installation. I have configured OSGeo4W to install external packages with pip, but py2exe doesn't seem to install with pip. If I try to use the downloaded installer, it only finds the system install in the registry. Any ideas how to get it working?

3 Answers 3


I've had better luck with pyinstaller than py2exe. It pretty much works out of the box for me with o4w python (you may need to install the optional python-win32 package). Follow the install instructions, and run the Build step. I didn't need to get into manually altering the spec file or even using options (other than --onefile for end user simplicity). Just make sure you run from inside the o4w shell so pyinstaller finds the right python environment. Here is my pyinstaller build batch file. There is only one line that does the real work:

python pyinstaller.py --onefile --out=%path\to\distrib%\myexe-%rev% %path\to\my\file.py%

Not to say py2exe can't work, it's just been so long now I no longer remember where I ran into difficulties with it or what the possible solution routes were.

  • Thanks, matt, this is a good alternative option and I'll give it a try. Oct 2, 2012 at 16:51
  • I ran into a snag with this approach: pyinstaller needs pywin32 to work on Python 2.6+. Fortunately it can be installed using the o4w setup program. Oct 2, 2012 at 18:49
  • I added note re: python-win32 requirement, thanks rudi Oct 2, 2012 at 21:41
  • As a followup, I managed to create the exe without any problems using this method. When it came to running the executable, I kept getting ImportError: No module named _gdal. I thought it was a problem with the pyinstaller hooks, but it seems it's actually an environment issue in OSGeo4W, since I could get it to work fine from a regular cmd prompt (ie not o4w shell) as long as the GDAL_DATA environment variable is set. I wrote more on this at StackOverflow. Oct 3, 2012 at 8:15

I was able to get py2exe to work using a suggestion from wildintellect on IRC. After installing py2exe on the system python, I checked the install log (c:\Python27\py2exe-wininst.log) and copied the files into the o4w python installation (c:\OSGeo4W\apps\python27\lib). Basically, that meant the following files and directories:


I also had to copy these DLLs into C:\OSGeo4W\apps\python27\DLLs to get it to link properly (basically I searched the c:\windows directory and copied across whatever caused it to fail):


There may be reasons why this is a bad idea, but if you are set on using py2exe, then this seems to work.

  • 2 days...good to know. Also, no matter who gets the credit, at least we all have another osgeo4w problem solved! I am sure you are not the only one who wants to use py2exe.
    – s_a
    Oct 2, 2012 at 19:52

one option would be to add the osgeo python to your windows registry: http://effbot.org/zone/python-register.htm

this site also contains information on how to remove it from the registry if you so desire.

I am pretty sure this will help you as long as you have admin rights to the registry.

  • Thanks, that would work, except for the following: "Note that there can be only one registered interpreter for each major Python release (e.g. 2.0, 2.1, 2,2 etc)" Both are 2.7 Oct 2, 2012 at 14:29
  • I was envisioning using it temporarily. ie. taking the C:\python version out of registry and using osgeo\python and then switching back later...best I could think of :)
    – s_a
    Oct 2, 2012 at 15:06
  • 2
    Please see add/remove the o4w python to/from Windows registry on osgeo4w website for an improved version of the effbot recipe, made specifically for o4w. Oct 2, 2012 at 16:16
  • I should have looked there first! thanks mattwilkie
    – s_a
    Oct 2, 2012 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.