2

I am using ArcMap 10.7.

I am somewhat new to geospatial data analysis and have an analysis question that I am hoping the community here might be able to assist with. I am working with a large raster file (NLCD 2016 CONUS) covering the contiguous United States (file type == '.img').

My object is (theoretically) simple: I want to use a polygon shapefile of the lower 48 states to clip (my initial guess for the appropriate tool, but open to other suggestions) the raster so that I have pixel information for each state in the attribute table. This would allow me to more easily perform downstream statistical summaries of the data that are state-specific.

My initial approach was to use the Data Management Tools --> Raster --> Raster Processing --> Clip function with a shapefile of the lower 48 as the Output Extent. I did choose ouput raster format as '.tif'; not sure if this is problematic.

enter image description here

However, after nearly 8 hours of processing time, the resulting clipped raster did not have an associated attribute table and did not retain the land cover pixel information from the original file.

I am hoping for some general feedback on this issue and modifications to my approach (maybe clip isn't the best tool...) that might be more successful. I am exploring other tools, but the enormous size of the dataset limits my ability to experiment with several different tools.

2

You say:

My initial approach was to use the Data Management Tools --> Raster --> Raster Processing --> Clip function with a shapefile of the lower 48 as the Output Extent.

From that description it sounds like you have a single shapefile with 48 polygons representing the lower 48 states. The tool has likely used all polygons so it's clipping out a massive area with all the polygons simultaneously. Imagine dissolving the boundaries between the state polygons to create one "mega polygon". So you have 1 huge polygon clipping a huge raster, hence your long processing times.

Try SELECTING a single state then use that layer with the selection, this should clip out your land cover raster for just that state. Once you have verified this is indeed what you want you could use a very simple model in modelbuilder to iterate over the individual polygons and do the clip.

I suspect you need to recalculate the statistics of your output raster as well as rebuilding the Raster Attribute Table. Don't know what they are? Search the help file for the tools.

| improve this answer | |
  • Thank you for the detailed response. Selecting individual state polygons in the shapefile worked perfectly, and I can use modelbuilder to iterate over the remaining states. One issue persists though: the clip converts the different pixel values in the original raster to a single pixel classification (value = 0). Even after I recalculate statistics and use the Build Raster Attribute Table tool, this remains the case. For some reason, the pixel information is not translating correctly during the clip. Any idea what I am missing? – Alexander Martinez Jan 15 at 0:02
  • Do the output images have a Raster Attribute Table (.dbf) file associated with them? You would think if the original has raster attributes the clipped would also. According to the help the environment resampling method is used by the Clip_management tool, try to avoid resampling by setting Snap Raster to your original, then if the attributes haven't been maintained build the RAT and use Join Field to copy the values from the original to the clipped. – Michael Stimson Jan 15 at 0:38
  • Thanks. I re-ran clip to avoid re-sampling, which seems like the right choice since it maintains pixel size of the original raster. However, the output .img file att_table remains the same: a single row, pixel class value = 0, and all the pixel counts have been lumped into this single category. Really odd. I looked at options for Join Field -- will this work given that the clipped raster attribute table has only a single row? That is, rows from the original raster file table with the appropriate pixel values are not present in the clipped table. Any add'l insight is appreciated – Alexander Martinez Jan 15 at 19:54
  • I just ran the clip on that dataset then rebuilt the RAT and I get a normal attribute table... My output format was tif, nodata was set to zero, snap raster environment was set to the img file. Then for rebuilding the RAT , I ticked on overwrite. All came out as expected. Make sure you have no selection on the raster. – Hornbydd Jan 15 at 23:42
  • @Hornbydd, just to clarify the parameters for the clip you executed. Input Raster == NLCD.img; Output Extent == states.shp (I made a single small state a selected feature); Use Input Features For Clipping Geometry == CHECKED; Output Raster Dataset == .tif format, NoData Value == 0, Maintain Clipping Extent == UNCHECKED. In the environment settings I set Snap Raster == NLCD.img file. Once the clip was complete with these settings, I used Build Attribute Table with overwrite == CHECKED. The result this time was a completely empty raster attribute table. Have I misinterpreted your process? – Alexander Martinez Jan 16 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.