3

I have a legend in my QGIS print composer and would like to manually move a layer to position them where I want them to be. In the following example I would like to move the layer "area" down to the same postition as "Messtationen". Is there a way to do that? Ideally, a drag & drop function but other ways are also fine.

enter image description here

6

Not a real solution, but a nice workaround I often use:

Create a new temporary layer in your project and assign a complete white symbology (or transparent / or the color of your background in print composer) to it. Then add this layer to your legend and remove its label. Now you can use it as "dummy placeholder" to create gaps and e.g. move it right on top of area, so area moves down.

1) the original layout

enter image description here

2) creating a new temporary layer (without adding actual geometry to it) and assigning transparent/white/background color

enter image description here

3) adding this new temporary layer to print composer legend

enter image description here

4) removing its label and moving it into its placeholder position

enter image description here

Then again, this would be a nice feature request.

|improve this answer|||||
2

I'm offering you a solution that isn't elegant, but it works. You can add 2 legends in your print composer:

  1. one with the layers gonsbach and landbedeckung with 2 columns.
  2. a second one with the layers Messtationen and area with 2 columns too.
|improve this answer|||||
0

In the print composer > legend properties > column

  1. Select the number of the column
  2. Unclick the option of split layer
  3. The item order can be changed using the enter image description here and arrowDown buttons or with ‘drag-and-drop’ functionality. The order can not be changed for WMS legend graphics.

https://docs.qgis.org/3.4/en/docs/user_manual/print_composer/composer_items/composer_legend.html#legend-items

Done!

|improve this answer|||||
  • When I unclick the "split layer" option I still can't move the legend elements. It seems to me the "split layer" option only makes sure that all the columns have the same height. – DGIS Jan 20 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.