0

I followed the following description of a data defined setting so that each page gets the predefined scale.

Atlas Scale Focus off

I have two "scale" coloumns with types integer and integer64 and the coverage layer is correct. However when I want to append the new scale field, I don't get any options to append.

enter image description here

What could be possible Errors? The setting makes perfect sense to me, it should work...

1
  • You have opened the wrong box (Kartenausdehnung instead of Maßstab). Try the one above. – MrXsquared Jan 20 '20 at 17:18
1

Once again, it's better to know the version of QGIS...!

I don't think the way you was looking for could right because in this case the scale is controled by the atlas, so the right dialog box it's below.

https://docs.qgis.org/3.4/en/docs/user_manual/print_composer/composer_items/composer_map.html#controlled-by-atlas

You can't set a ruled based scale in print composer, because qgis focus on one objet per map, so it adapt it object by object

But the best you can do is to use the Predefined scale (best fit) option.

You can configure it here : https://docs.qgis.org/3.4/en/docs/user_manual/introduction/qgis_configuration.html#predefinedscales

1
  • yes I need to keep in mind to add the version... I don't know why, but if I close the atlas for a moment and click the map item off for a moment and than open the atlas and activate the map again, than it actually works. I agree that the predefined scale is the easier and better option, I was still interested how the other option works. – DGIS Jan 20 '20 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.