4

I have been working with QGIS for a few years now and am just now having issues with the GRASS module. Ultimately, I am just trying to split a line (river) into 100m segments, and have found the solution 'v.split' from the GRASS module to work in the past. However, it is now not working. When I attempt to do this now, I get a string of the following errors, mixed in with other gray script:

WARNING: Datum <unknown> not recognised by GRASS and no parameters found
WARNING: Column 'FNODE_' : type int8 (bigint) is stored as integer (4 bytes) some data may be damaged
WARNING: Unable to create index
WARNING: Unable to copy table <test> for layer 1 from <vector_5e261eb3399f04@PERMANENT> to <outputd6fac97d69a74c25b15df5ddcab257ba>
ERROR: Key column <> not found

Here are my v.split inputs and some system settings:

Screenshot of my inputs for v.split

I'm at a bit of a loss here. This was working before, but now I am unable to use any of the GRASS tools. Is there someone who might be willing to briefly provide a description of how to properly set up GRASS in QGIS so that it works properly?

For what its worth, I am running a MacBook with OS 10.14.6

And, here's a screenshot of how I have my GRASS settings configured: GRASS Settings

I'm just a biologist trying to do biology....

1
  • the first warning you get is grass telling you it doesn't recognize the coordinate system used it seems. normally Gras fixes that on its own. I'm wondering if since you are using the newest version of qgis, this hasn't been updated. I tried create a shaefile with the same coordinate system in the same region and got it working no problem. try it using qgis long term release (3.4.12)
    – B-C B.
    Commented Jan 20, 2020 at 22:55

1 Answer 1

2

I got a similar problem with Grass, so I deleted these folders

C:\Users\MyUser\AppData\Roaming\GRASS7 C:\Users\MyUser\AppData\Roaming\QGIS C:\Users\MyUser\AppData\Local\QGIS And GRASS worked again.

Be warned! Lost all plugins installed and configurations... had to reinstall them.

1
  • This solved the problem for me too. Thanks. Commented Apr 27, 2023 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.