I tried to georeference a LANDSAT scene in QGIS 1.8 but I failed. My first question is Can I use geografical coordinates as x,y coordinates of control points? or I need projected coordinates (from Campo Inchauspe/argentina 4 for example)?

I used the geographical coordinates (lat; long in dd mm ss) and I obtained a black small (less than 1 meter) image.

  • Hi, It sounds to me like you need to set the CRS in the properties of the georeferencing window before creating the projected image. From the 'Settings' drop-down go to 'Transformation Settings' and set the 'Target SRS' to what you need. I am pretty sure you can georeference the image in either wgs84 or in your local projection. Hope that helps :) – s_a Oct 3 '12 at 15:03
  • 2
    Most probably you should enter lat/long in decimal degrees, not minutes and seconds. – AndreJ Oct 3 '12 at 15:49
  • 2
    If I'm not mistaken, LandSAT imagery is already georeferenced in some UTM zone. In that case, you don't need to georeference, only perhaps reproject to some other CRS. – Micha Oct 4 '12 at 6:43

I had the same problem with QGIS 1.8. I wanted to correct PAN images (WGS84, UTM) providing new GCP and keeping the same projection. It fails, the new image is projected far from its supposed location.These two links suggest (sorry I can't be sure) there is a bug.



To resolve this, I translated the image into jpg and georeferenced it again, back to WGS84 and UTM. It slightly alter the polygon it seems and this is far from being satisfying. I have seen a possible solution in the first link above. But help is welcome here!


I was facing the same problem here. QGis georeferencer appears not to work if the image already has a coordinate system set. I'm using QGis 1.8.0 from OSGeo4W install. I believe this is related to the bug 2456 [1] mentioned in the above answer however, the bug status says it's closed.

I got around this issue by removing the georeferencing information. To do that, I ran gdal_transform (translate command in QGis Raster / Conversion) and used the Creation Option PROFILE=BASELINE [2].

After removing the coordinate system information, I was able to georeference the image.

[1] - http://hub.qgis.org/issues/2465 [2] - http://lists.osgeo.org/pipermail/gdal-dev/2011-June/029116.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.