2

I am attempting to run a model that iterates rasters and computes zonal statistics returning a table. The raster's statistics are computer across all polygons in a specific shapefile. This model worked for a small amount of files (3), but when I am trying to use it for my entire Geodatabase it will not work, returning the error shown below. Error 999999

My model looks like this: Model diagram

I have around 300 rasters I am trying to find the statistics for, and they are listed in my geodatabase like this: Catalog

I am using the file pathway of a new folder followed by %Name% as shown in the Model Diagram. When executing the model non-iteravely,it completes when the file name is something random, say, "new", but when using the /%Name% as the file name, it returns that the characters are invalid.

I am very confused as to why this model worked for the test run of just a few files but not for the entire geodatabase.

11
  • 1
    try without blank spaces in your paths (eg E_MS_Epi_Theses). It often helps. – radouxju Jan 28 '20 at 15:33
  • Done, still the same error. – coconn41 Jan 28 '20 at 15:58
  • Does NYS_ZCTAs share the same coordinate reference system as the input rasters? If not, reproject those data and try again. – GBG Jan 28 '20 at 16:17
  • Reprojected, still the same error. – coconn41 Jan 28 '20 at 16:28
  • Could you try outputting them outside of a gdb? Do you have permissions to write to the folder ? – GISKid Jan 28 '20 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.