0

I have two different versions of QGIS at work – v3.6.3 and v2.18.3. We have a GeoServer v2.14 that I want to pull features from via WFS requests. I can pull features when using QGIS v2.18.3 but I receive a “DescribeFeatureType failed” message when using QGIS v3.6.3. I have two questions:
1. Is there a way within QGIS to see how the WFS requests are constructed in the two versions of QGIS? 2. Is there a way to customize the WFS requests in QGIS3?

5
  • 2
    You should be able to find the incoming requests from the GeoServer logs. You may need to raise the logging level to GEOTOOLS_DEVELOPER. – user30184 Jan 29 '20 at 20:59
  • 1
    The method described in gis.stackexchange.com/questions/241400/… may also help see what the difference in the requests are – Ian Turton Jan 30 '20 at 8:09
  • @user30184 An admin monitored GeoServer when I tried to connect qith QGIS 3.6.3. It seems that QGIS is not keeping and reusing the cookie what is returned to it from the first authentication. According to the admin, this issue could probably be resolved if one of two things happen; (1) keep the cookie and reuse it or (2) allow more redirects. We are using Oracle Webgate OAUTH and QGIS is not responding to the third redirect. – slalomchip Jan 30 '20 at 17:51
  • @IanTurton I like the concept you provided. Unfortunately I do not have privileges to setup TinyProxy to the network. – slalomchip Jan 30 '20 at 17:54
  • There's a python one I use as a user. – Ian Turton Jan 30 '20 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.