In QGIS 3.8.2 I georeferenced a set of aerial photos from USGS Earthexplorer website and decided that I need to photoshop them to brighten them. So I photoshopped the original ungeoreferenced source images and saved them at the same resolution/size.

Then I opened one of these processed images in QGIS Georeferencer and loaded the GCP points I had previously created for the unprocessed source image. The points load above the processed image as shown in the picture below.

There may be some geodata in these images from the USGS website that gets reversed somehow when I am saving them in Photoshop?

I have check the image sizes and the processed and source images are exact same pixel dimensions.

I tried georeferencing the processed image with four points, then reloading the outputted raster back into georferencer, and loading the original set of GCP's but got same result.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

  • I don't have a solution for you, but the best-in-class tool for debugging EXIF tagging issues is exiftool.org You could try examining the EXIF tags in detail of the pre- and post-photoshopping photos to figure out what has changed, and then you can use the same tool to batch write corrections to fix it?
    – Houska
    Commented Jan 29, 2020 at 20:31
  • Thanks for the reply Houska. I downloaded Exiftool and here are the exif data for the two images. First attached picture here is the exif data for the unphotoshopped image. Second shows the photoshopped version. The photoshopped image has a lot of exif data that isn't on the original image. For the exif data which appears on both images, here are the fields which appear to differ: Strip Offsets: Row per strip Commented Jan 30, 2020 at 18:39
  • I added the EXIF data images above in original post. The top two images of EXIF are from the photoshopped version. The bottom one is the original from USGS. Commented Jan 30, 2020 at 18:51
  • Sorry, didn't realize these are tifs not jpegs (geotagging is in native exif tags in jpeg but it's in geotif not plain tif...not sure of the import of this). However, glancing at this again, would the problem be fixed if you manually moved the images so their current BL corner were where their current TL corner is? There are 2 conventions for images, with y going upwards from BL or downwards from TL. If that somehow got munged, rather than finding the cause and redoing work, you might be able to postprocess your GCP points and/or world files to post-correct. Esp if the images are same size!
    – Houska
    Commented Jan 30, 2020 at 19:01
  • Thanks Houska. I ran the exiftool -all= image.jpg command and that didn't change the problem. So after reading your comment, I opened both the original and the processed images in Georeferencer and compared the raster properties info for both. The processed image has a different extent from the original image. See image I added to the original post showing this. This seems to be getting at what you are saying. By the way, there is no world file for the processed image. Would it help to copy one from the folder that the original file is in and put in the processed images folder? Commented Jan 30, 2020 at 20:32

1 Answer 1


Try using Paint.NET.

As of my last testing (GIMP, Affinity, Photoshop), this is the only "traditional" image editing software to properly preserve GeoTIFF metadata. Be aware that at current, not all bit-depths found in GeoTIFFs are supported, but "major" ones are (32bit, 24bit, 16bit, etc).

Fixed: EXIF metadata of type Float and Double are now supported.
This ensures GeoTIFF metadata is preserved.

See the Paint.NET release notes here:

@EvenRouault @nyalldawson @qgis @OSGeo
Absolutely awesome work, Rick!
Thanks so much!
This opens up the door to SO many possibilities, especially when redacting/modifying/cleaning up imagery.
I can't thank you enough for your hard work on this!

See a tweet testing this capability here:
https://twitter.com/Brett_E_Carlock/status/1174447891169103872 enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.