3

I have a rivers layer which I am trying to get "Curved labels" on. When I zoom in the layer is labelled correctly with curved labels. However, when I zoom out the curved labels disappear completely.

I know other people have posted this question before and was wondering if anyone had found a solution to the problem ?.

Parallel labels works fine at all scales. I've also attempted playing with the 'Max angle between curved charachter setting' but this still dosn't solve the issue.

0

2 Answers 2

9

I think this long-term bugbear should have been addressed with the "overrun distance" setting in QGIS version 3.10. See extensive discussion at https://github.com/qgis/QGIS/issues/15846 and the links there.

The issue is that when you're trying to curve labels, when you zoom out the labelling engine runs out of possible wrap-around locations where to place the labels. Previous locations not only get crunched since label length increases relative to map units (this happens with all labels), but previous good candidate locations now run out of feature to curve around or curve too much. It requires explicit logic to decide when to (not) give up, and what to do next rather than just "don't label".

If you can't solve your specific problem with this setting (and you're using 3.10), would suggest you open an issue to bug fix. Since the setting/logic change is new and was finicky, it's possible some glitches could remain, I suppose.

4

Try setting "scale dependent visibility" on. Perhaps they are set to draw only at a certain scale. Please check under the rendering tab in the labeling dialog box.

enter image description here

2
  • Thanks for your response. That is what is confusing. I have scale dependant visibility un-checked but QGIS is acting as if it is turned on.
    – JohnF
    Jan 30, 2020 at 2:55
  • 1
    @Houska is right, however, since the small lines cannot be labelled for now, I suggest you duplicate your existing layer and then simplify the geometry under Vector---> Geometry Tools --->Simplify . Then you will need to toggle between the 2 labelled layers by setting the "Scale Dependant Visibility" under the "Rendering" tab which is available in the layers' property. You need to check which scale is acceptable for one layer to be visible and the other not to be visible.
    – GforGIS
    Jan 30, 2020 at 23:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.