2

I recently installed the version 3.10 update of QGIS, and the xyz tile imagery stopped rendering. It originally showed up when opening a project saved under a previous version (3.8.3), but it also does not render if I add new layers.

I've tried adding several different xyz tiles (eg. Bing, Google, Open Street Maps, NAIP from web), and none of them show up. Local raster imagery shows up and renders fine. The xyz tiles render correctly if I open the projects in the older version.

I'm running QGIS(64-bit) 3.10.2-A Coruña on a Windows 8.1-pro 64 bit system.

After looking for similar problems on stack exchange, I tried running the script from this github link to connect with online resources following the accepted answer on question 285179. This added additional xyz layer options, but did not affect the behavior. Layers are able to be added, but do not render under some projections/CRS's.
I tried starting with a clean, empty project and adding the xyz tiles before any local data, but this does not appear to affect the rendering issue. If I add xyz layers in QGIS 3.10.2 and save the project, then open with a previous version of QGIS (3.8.3) they render fine. This suggests it is not an issue with the layers not being added correctly.

After further investigation, the xyz tiles render correctly with some coordinate systems, but not others.
My original project was in EPSG 2285 (NAD83 Washington State Plane North). The tiles do not render in EPSG(ESRI):32148, EPSG 2286 (NAD 83 Washington South), EPSG 32048 or 32049 NAD27 Washington North or South, respectively.

These layers render fine in: EPSG 4326, 3857 (versions of WGS 84) EPSG 6339 (UTM zone 10N) EPSG 6597 (NAD 83 (2011) WA state Plane) EPSG 2855 (NAD 83 HARN Washington North)

1

With help from Nyall Dawson and Givanni Manghi, there appears to be an issue with transformations with limited geographic extent and xyz tiles.

To correct the issue:

  1. Determine the CRS of the xyz tiles for Google Satellite this is EPSG 3857 - Pseudo-Mercator.

  2. Go to Project Properties > CRS. Select the plus button under Datum Transformations.

  3. Select appropriate from and to CRS's and choose a transformation that does not have limited geographic extent. For EPSG 3857 to EPSG 2285 this is the second option with a lower accuracy.

  4. Apply/Ok back to main screen and pan or zoom, and the layers render.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.