1

When I run QGIS the log messages panel shows something like this: problem with SAGA installation: SAGA version non supported (found 7.4.0 required 3.2.). But in a ubuntu shell the command "saga_cmd" returns SAGA Version 2.3.1. I removed and reinstalled SAGA but the problem is the same and isn't possible to use SAGA. Any idea?

  • I had a similar problem. See the answer here gis.stackexchange.com/questions/345121/… – GBG Jan 31 at 19:29
  • Thanks, solved. I changed the SagaAlgorithmProvider.py file directly, by: sudo nano /var/lib/flatpak/app/org.qgis.qgis/x86_64/stable/e91e50d2655800d4ad1fa98ec7a827703eaffb214a8820521239e8ceb9d8f7f8/files/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithmProvider.py: then I changed the REQUIRED VERSION from 2.3. to 7.4.0 – Federico Pav Jan 31 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.