1

I am trying to install QGIS on Linux Mint 19.3, using the synaptic software manager. I had QGIS 3.10 installed with flatpak, but wanted to get it to show up on synaptic so I could update it when needed. I am not sure if I should be using debian or ubuntu repositories. I tried debian and got a lot of missing and uninstallable packages listed.

BTW, I have used QGIS extensively on Windows for years, but I am trying to abandon Windows 10 on my Windows 7 workstation.

In response to a comment by DPSSPATIAL yesterday, I used the link provided to follow the detailed instructions given there for installing QGIS. Here is the resulting failure: dwayne@dwayne-HP-Z1-Workstation:~$ sudo apt-get install qgis python-qgis qgis-plugin-grass Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: python-qgis : Depends: python3-qgis but it is not going to be installed qgis : Depends: libc6 (>= 2.29) but 2.27-3ubuntu1 is to be installed Depends: libgdal26 (>= 1.11) but it is not installable Depends: libgsl23 (>= 2.5) but it is not going to be installed Depends: libproj15 (>= 4.8.0) but it is not installable Depends: libqgis-3d3.10.2 but it is not going to be installed Depends: libqgis-analysis3.10.2 but it is not going to be installed Depends: libqgis-app3.10.2 but it is not going to be installed Depends: libqgis-core3.10.2 but it is not going to be installed Depends: libqgis-gui3.10.2 but it is not going to be installed Depends: libqgis-native3.10.2 but it is not going to be installed Depends: libqscintilla2-qt5-15 (>= 2.11.2) but it is not installable Depends: libqt5core5a (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.4 is to be installed Depends: libqt5webkit5 (>= 5.212.0~alpha3) but 5.212.0~alpha2-7ubuntu1 is to be installed Depends: libqt5widgets5 (>= 5.11.0~rc1) but 5.9.5+dfsg-0ubuntu2.4 is to be installed Depends: libspatialindex6 (>= 1.8.1) but it is not installable Depends: python3-qgis (= 1:3.10.2+99unstable) but it is not going to be installed Depends: qgis-providers (= 1:3.10.2+99unstable) but it is not going to be installed qgis-plugin-grass : Depends: qgis-provider-grass (= 1:3.10.2+99unstable) but it is not going to be installed Depends: grass782 but it is not installable Depends: libgdal26 (>= 1.11) but it is not installable Depends: libproj15 (>= 4.8.0) but it is not installable Depends: libqgis-3d3.10.2 but it is not going to be installed Depends: libqgis-analysis3.10.2 but it is not going to be installed Depends: libqgis-app3.10.2 but it is not going to be installed Depends: libqgis-core3.10.2 but it is not going to be installed Depends: libqgis-gui3.10.2 but it is not going to be installed Depends: libqgis-native3.10.2 but it is not going to be installed Depends: libqgisgrass7-3.10.2 but it is not going to be installed Depends: libqscintilla2-qt5-15 (>= 2.11.2) but it is not installable Depends: libqt5core5a (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.4 is to be installed Depends: libqt5webkit5 (>= 5.212.0~alpha3) but 5.212.0~alpha2-7ubuntu1 is to be installed Depends: libqt5widgets5 (>= 5.11.0~rc1) but 5.9.5+dfsg-0ubuntu2.4 is to be installed Depends: libspatialindex6 (>= 1.8.1) but it is not installable E: Unable to correct problems, you have held broken packages. I have no idea what to do about broken packages. I have reached essentially the same point in trying to install QGIS with other detailed instructions. My guess is that the broken packages result from having QGIS 3.10 installed from flatpak, and using the uninstall provided on the menu to remove it. I have also fumbled around to get PostgreSQL 12 working, and may have left some remnants from installing and uninstalling version 10 using the EDB Installer. I am about ready to give up getting a good installation with apt and use timeshift to go back to a working version.

I guess I am just in too big a hurry to get up and running -- I started learning Linux a month ago and still don't have a running set of GIS applications (QGIS, PostgreSQL, and PostGIS).

1

I installed LM 19.3 and found it easier to install qgis 3.10 from Flatpak. After it was installed I wanted to use some grass7 routines from the toolbox and was informed that Grass was not in the path. I struggled with that for a while and had the same experience with SAGA. Other frustrations eventually prompted me to make a fresh install of LM 19.3 During that time I began to wonder if somehow a flatpak installation was "invisible" to things installed via synaptic or from the command line and I followed this https://freegistutorial.com/how-to-install-qgis-on-linux-mint-19/ And then everything worked just fine. I continue to have some reservations about flatpak, but am not sure that I understand what happened well enough to have a healthy prejudice toward it. I like the concept, but am I mistakenly linking two events?

|improve this answer|||||
0

I finally gave up on installing QGIS with apt or synaptic, and used Flatpak. So far, it seems to be working with QGIS 3.10.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.