2

enter image description hereI am new to QGIS, need your help in fixing one problem. I created a Plugin for QGIS. While creating it, I worked on QGIS 3.10 LTR version for which my plugin is working perfectly.

Now when I shared this Plugin folder with my friend who is using QGIS 3.4 LTR version, the Plugin execution is giving error with the message like there was errors executing the algorithm.

I am unable to figure out about exact problem.

3
  • Welcome to gis StackExchange. What is the exact error message? LTR is now 3.10. Why not have your friend upgrade? Feb 6, 2020 at 15:27
  • @HeikkiVesanto, Thank you for the reply. I added the image for the error message in the post. As it is multi line message. Feb 6, 2020 at 15:34
  • 4
    It would be really better to post the error message as text
    – J.R
    Feb 6, 2020 at 15:38

1 Answer 1

4

I encountered this problem. Some processing tools worked in QGIS 3.8, but doesn't work in QGIS 3.4.

I don't know the reason, but changing native word into qgis in all processing.run ("native:tool_name", ...) solved the problem. (native:intersection -> qgis:intersection)

1
  • Thank you Kadir. This solution worked. Feb 18, 2020 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.