0

enter image description hereI would like to use the CleanTopo2 raster from http://shadedrelief.com/ to generate a hillshade for a main map of the conterminous United States and inset maps of Alaska and Hawaii (plus portions of bordering and nearby countries within the map extent of each). However, when I try to project the raster and other map layers with an Albers projection, the vector layers look fine but the raster does not align with them. I initially thought that maybe I need to correct how the CleanTopo2's SRS is initially defined before reprojecting it, but I'm not sure if that is the only thing causing the issue since the CleanTopo2 and other layers initially align just fine with a WGS84 projection (and with a custom projection applied to the raster). I first created a custom projection based on Data_Info.txt file that came with the CleanTopo2 dataset--the text file contains the following information:

Projection: Plate Carree aka Geographic or "LatLong"
Earth ellipsoid: Sphere, radius 6370997 m
Datum: WGS84
Extent: 180 West to 180 East, 90 North to 90 South
Size: 10,800 height samples wide x 5,400 high
Resolution: 2-arc minute (about 3.7 km/degree)
Elevation range: -10,701m to 8,248m

I also tried simply defining the projection as WGS84 (ESPG:4326). I'm not 100% sure that I defined the custom projection correctly but both methods that I used to define the CleanTopo2 projection (i.e. custom projection and ESPG:4326) display the raster and other shapefiles (containing an ESPG: 4326) aligned.

However, when I next try to reproject the CleanTopo2 and other layers with an Albers projection (as a first step...I will need to reproject everything again with different projections for Alaska and Hawaii inset maps), the global shapefiles project fine but the raster gets extensively sliced up (see attached image) and doesn't align with the other shapefile layers at all. Can anyone please help me figure out how I can get this raster to project correctly and align with the other projected shapefile layers? I've tried to figure this out for a while but am really stumped.

  • Please, describe the taken steps in a way that others can reproduce them. Include a screenshot of the extensively sliced up output. – Gabriel De Luca Feb 15 at 22:51
  • @Gabrial, I've attached a snapshot of the output. The steps that I took to get this were to 1) run gdalwarp on the cleantopo2 raster with the target coordinate system set to ESPG: 4326-, then 2) run gdalwarp again with target coordinate system set to ESPG: 42303. – Nicole Samu Feb 18 at 15:12
0

I think I figured out the root of the issue with help from a friend--since Albers is a regional projection, its parameters aren't valid for a global extent. To get the raster into the Albers projection, I first clipped it down to an extent slightly larger than the land area that would need to be shown in the map and then reprojected it. That did the trick!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.