2

I created a map with labeled contour lines. When I am now adding the map to the layout view not all labels appear (e.g. 2000, 2500 and 3500 meters has a label, but not 3000)

[This image shows how contour lables look in layout.

In the original map the area with contour lines is a lot bigger, thus all contour lines show up how they should. How can I force QGIS to show the labels at a specific site in the layout without clipping my original file?

1

As a quick fix, go to Layer properties / Labels / Rendering and turn on Show all labels for this layer (including colliding labels). This should make all the labels appear, even if they collide with something else.

With this quick fix, you may now get colliding labels in your map canvas, and you will get them in all layouts, etc. If this is a problem, you can:

  1. Adjust labeling manually at the scale of the layout to make missing labels appear. In QGIS 3.10+ you can force showing "missing" labels in red so you can figure out how to make them visible (see Show/mark not visible labels (colliding labels) )

  2. Use the data-defined setting for Always show just below the setting I suggested in the Quick Fix to only activate in your layout and/or at certain scales.

  3. Create a copy of your contour layer that you only use in the troublesome layout, that has different label formating and/or the always show setting on, without affecting other layouts or the map canvas.

Finally, try playing with the font size on the contour labels, and with the Placement and the Overrun feature and Maximum angle settings under Label / Placement. It looks like your contour labels are curved, and if in the scale and restricted area of the layout QGIS can't find places to label where the curvy label will fit without exceeding the maximum angle, it won't place it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.