0

I import a list of points from a CSV file:

No of school    east    north
School 1    98,431388   22,883583
School 5    97,608888   22,854361
School 6    97,901388   22,549805

on a map:

myanmar

but the points always end up on the wrong place.

The points are clearly in the Shan State in Myanmar but when I use the add layer delimited text layer, QGIS uses the file, shows correctly the point coordinates, and then accept the add and close.

Where do I go wrong?

  • 1
    Your background map looks like google maps so the CRS should be defined, but what is the CRS of the project? – MortenSickel Feb 18 at 9:45
2

I think you must set , as decimal separator

enter image description here

At the end you will have

enter image description here

| improve this answer | |
1

Usually those kind of problems are caused by some mistakes on CRS. Make sure that your background map is correct (it looks like google maps, so it should be fine), that your project and the data you import has a defined CRS.

| improve this answer | |
1

Your marked red point on the map in your question seems to be precisely at latitude 0, longitude 90 east. This makes me suspect an error in picking out the right data (columns) for the geometry for the import rather than a CRS issue.

To debug failed delimeted text imports:

  1. Take a look at the imported layer's attribute table (F6 with layer selected), and list of fields under Manage fields in layer properties. Are they correct? If not, QGIS is misinterpreting the structure of your CSV file. Try re-adding the layer (as delimited text), paying meticulous attention to the settings under 'File format' and 'Record and field options'. In particular, in the snippet you posted, potential pitfalls include using CSV under File format (since then the comma between 98 and 431.. would be used as a separator), or errors in Record and field options e.g. comma as decimal separator and trim fields.

  2. If the data shown in the attribute table is correct, the error is in interpreting that as geometry. In (re)importing the layer, pay attention to the settings under Geometry definition. In order to debug what is going on, go under Layer properties / Manage fields, then use the Field Calculator (icon line at top, extreme right) to create a virtual field, named (e.g.) WKT, format Text, and in the expression field enter geom_to_wkt($geometry). Then get out of layer properties and reopen the attribute table. You should see an additional column called WKT representing what QGIS thinks is the geometry as text. You want it to read Point(98.431388 22.883583) for your school 1. If it's different, what is there may help you debug what went wrong under the Geometry Definition settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.