1

I have added a field to two news feature classes - one of the fc's is in a dataset and the other is in a database in the SDE. The new field, in each fc, needs to have three domain choices, seen in the image in the Coded Values section. enter image description here

But the choices that appear in the table with the dropdown arrow are , Legacy, OneFiber, and OneFiber.enter image description here

When I access the Subtypes tab in the feature classes, I can't do anything because it is completely greyed out. How can I add these choices? Edit: I have now run the Create Domain tool and the Add Coded Value to Domain tool (image):

enter image description here But the Assign Domain to Field tool failed. I think the problem is that I don't know how to create more than one value choice for the domain. enter image description here

  • Have you assigned the domain to the field in the feature class' properties, 'Fields' tab? – Son of a Beach Feb 18 at 22:04
  • I have created the domain and added the values. My original post now has screenshots of the add coded values tool and the error message I got when I ran the Assign Domain to Field tool. Regarding the Layer Properties > Field tab, the Field Details, including Coded value domain, are all greyed out. – Regulus Feb 19 at 15:25
1

I believe I have discovered the solution. The field I assign the domain to apparently needs to be large enough to accommodate all the characters in all the choices combined, instead of just large enough to accommodate the largest value. I needed to run the Add Coded Value To Domain tool once each for each value. Then I ran Assign Domain to Field and all the value choices now appear in the dropdown menu of the field.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.