3

I had a version installed, I think it was 3.4.10, and used it couple months back it worked great. I tried opening it yesterday and it took forever. I uninstalled it and installed the latest version 3.4.15 and that is also taking forever. I can't use it all. I uninstalled and reinstalled and still super slow. I see this is big problem but can't find a fix. Im on Win10 Pro.

2
  • most likely a plugin try running QGIS without them gis.stackexchange.com/questions/272772/… – Mapperz Feb 21 '20 at 1:56
  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Please check out our short tour to learn about our focussed Q&A format. – PolyGeo Feb 21 '20 at 8:57
5
  1. Try to upgrade to the latest version.My suggestion is that you remove version 3.4.x and install the latest version 3.10.

  2. From my experience QGIS loads slowly when we have too many plug-ins installed. Try removing those that you do not need.

  3. Just to make sure that the issue is not related to your PC, try to install QGIS on another machine and see if the same problem occurs. Sometimes even antivirus could be the cause.

8
  • 1
    3.10 is no different. Still painfully slow. I hate it. Can't get anything accomplished. – Adam Feb 21 '20 at 4:35
  • 1
    its taken 20 minutes so far to open. Why are all the plugins on by default if they create so many issues? I dont understand. – Adam Feb 21 '20 at 4:43
  • 1
    check the link provided by Mapprez and see if that is really the issue. – MyGIS Feb 21 '20 at 4:47
  • 1
    opened using command line --noplugins and it still will not open. It seems worse than 3.4 – Adam Feb 21 '20 at 4:58
  • 1
    Did you switch off the antivirus? Have you tested on another computer? – MyGIS Feb 21 '20 at 5:03
3

I had a very similar issue and eventually resolved it by accident when I finally disconnected a hard drive that had failed, but was still being recognized by Windows 10 as present. QGIS was trying to scan the drive during startup. Disconnecting the drive led directly to a resolution of the issue.

0

Try to close the QGIS browser tab!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.