5

I had a version installed, I think it was 3.4.10, and used it couple months back it worked great. I tried opening it yesterday and it took forever. I uninstalled it and installed the latest version 3.4.15 and that is also taking forever. I can't use it all. I uninstalled and reinstalled and still super slow. I see this is big problem but can't find a fix. Im on Win10 Pro.

2
  • most likely a plugin try running QGIS without them gis.stackexchange.com/questions/272772/…
    – Mapperz
    Feb 21, 2020 at 1:56
  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Please check out our short tour to learn about our focussed Q&A format.
    – PolyGeo
    Feb 21, 2020 at 8:57

5 Answers 5

5
  1. Try to upgrade to the latest version.My suggestion is that you remove version 3.4.x and install the latest version 3.10.

  2. From my experience QGIS loads slowly when we have too many plug-ins installed. Try removing those that you do not need.

  3. Just to make sure that the issue is not related to your PC, try to install QGIS on another machine and see if the same problem occurs. Sometimes even antivirus could be the cause.

8
  • 1
    3.10 is no different. Still painfully slow. I hate it. Can't get anything accomplished.
    – Adam
    Feb 21, 2020 at 4:35
  • 1
    its taken 20 minutes so far to open. Why are all the plugins on by default if they create so many issues? I dont understand.
    – Adam
    Feb 21, 2020 at 4:43
  • 1
    check the link provided by Mapprez and see if that is really the issue.
    – GforGIS
    Feb 21, 2020 at 4:47
  • 1
    opened using command line --noplugins and it still will not open. It seems worse than 3.4
    – Adam
    Feb 21, 2020 at 4:58
  • 1
    Did you switch off the antivirus? Have you tested on another computer?
    – GforGIS
    Feb 21, 2020 at 5:03
4

I had a very similar issue and eventually resolved it by accident when I finally disconnected a hard drive that had failed, but was still being recognized by Windows 10 as present. QGIS was trying to scan the drive during startup. Disconnecting the drive led directly to a resolution of the issue.

3

Seems this particular instance has been solved (a problematic plug-in), but I would add 3 other methods for trouble shooting these issues, that might help others stumbling cross here:

  1. After successful startup, browse the log messages (icon of voice callout with ... in it, bottom right of QGIS window). The error messages/warnings may provide a clue what went wrong, or at least their timestamps will help diagnose where things were stuck.

  2. Also after startup, turn on the Debugging/Development tools panel. You can monitor result of internet data requests (first category from the choice of 2 on the left via icon or dropdown on top) or startup profiling (2nd category), so you can see what is hanging or failing. (This was added in a recent version, 3.12 I believe)

  3. Go into airplane mode/otherwise turn off internet and try to start. Of course this will stop you from loading non-local layers (and be sure to not discard them from the project when the error message appears!) but is a way to start at all if it is taking so long you can't wait, and if the problem is timeouts on a layer load. You can then tweak Settings / Options / Network / Timeout to reduce timeout for network requests. To be safe, don't save your project with internet off (if it uses important non-local info and you don't know what you're doing). Change this setting and restart with internet back on to load everything except the problematic layer.

2

Try to close the QGIS browser tab!

1

Thank you to @Mapperz for an answer I overlooked - check your plugins- I only had 2. Like Adam I had issues with a project taking 60+ minutes to open and then stalling at 96%, taking forever to load multiple aerials and data layers

Overcame this by removing a "GISCloud" plugin for transferring data from asset collection to my GIS mapping. Suddenly my start up was less than a minute.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.