I'm attempting to solve this error:

ERROR 6: GEOS 3.8 or later needed for MakeValid.

The version of GDAL I am running is 3.0.4 which was downloaded as a .whl from https://www.lfd.uci.edu/~gohlke/pythonlibs/

The version of GEOS that ships with this .whl is unknown so I assume it's <3.8.

To that end I have downloaded GEOS 3.8.0 separately and managed to compile it sucessfully and generate the geos_c.dll and geos.dll to replace the ones in my current python installation.

The only issue is that the error remains still remains when trying to run the code.

  • Perhaps you must compile also GDAL again and point is to use the newer GEOS. – user30184 Feb 21 at 19:53
  • You may look at the question "How to check for DLL dependency?" stackoverflow.com/questions/7378959/… to track dll dependencies. It may help understand the issue and maybe fix it. – ThomasG77 Feb 21 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.