2

I have made it work by using dots instead of commas, and later change the CRS for the coordinates.


I am having problems converting the coordinate type: ETRS89 to WGS84.

I am unable to load my coordinates into QGIS 3. My data is simply 2 columns in excel, one column being x-coordinates and the other being y-coordinates, and it looks like so:

Extract of the data, much longer in full

I have copied it into the notepad, which is how i try to load it (which worked previously for another coordinate system type), and it looks like so when copied:

The data in csv format

It does not work when i upload it with settings as below:

Settings for upload

Instead of getting a layer in qgis, i get a table, depicted below:

The table


Does anyone know how to upload ETRS89 datapoints directly, or how to convert them?

Examples of x and y coordinates for ETRS89 are:

x:5,14858806438, y:55,2493152696999

10
  • 2
    Some existing transformations assume that ETRS89 is approximately equal to WGS84 and thus have zeroes for the transformation parameters. Is that what you're seeing--no values changing? What software are you using? Data's in the North Sea, correct? EPSG just added one last fall assuming epoch is around 2014. WKID is 9225.
    – mkennedy
    Feb 24 '20 at 19:44
  • 2
    @Oliver, Can you edit your question to include what the format of the data is? Are they geometries stored in some vector file or are they a list of coordinates in a CSV file? Please, also include in what application you want to import your points, how are you doing it and what is the issue found when doing it. Feb 25 '20 at 13:00
  • 2
    @Oliver, Seems to me that something in the process of import the text file as a QGIS layer is failing. Can you include a screenshot about that process? Are you importing a CSV vector layer? How do look the window of the source manager when you define the file to import? Feb 26 '20 at 13:10
  • 1
    If you're using the csv/text data window, make sure the radio button for geometry isn't set to "no geometry". That'd be a good reason why you end up with only tables. Would this answer work for you?
    – Gabriel
    Feb 26 '20 at 13:30
  • 1
    Somehow, I think this is an X - Y problem. You're trying to do two different things. Opening text data in QGIS, and reprojecting your data to WGS84. The two aren't really linked.
    – Gabriel
    Feb 26 '20 at 13:36
3

There are two steps to what you're trying to do, and it's easiest to do them separately:

  • Opening your data in QGIS
  • Reprojecting it to WGS84

Opening your data:

From the Data Source Manager, choose Delimited Text and make sure you're setting the point coordinates fields correctly, along with the CRS of your source.

enter image description here

Reprojecting to WGS84:

In the layers list panel, right-click on your added points layer and go to Export - Save Features As... and change the CRS of your output file to WGS84 (epsg:4326).

enter image description here

Getting WGS84 geographic coordinates:

If you need a table with the reprojected coordinates, then the simplest way without diving into expressions to deeply is to set the CRS in QGIS to WGS84 and add two fields in your attribute table for latitude and longitude, then use the field calculator with $x and $y as expressions to fill the columns:

enter image description here

The resulting values should be in decimal degrees, as seen in the Output preview from the last screenshot.

5
  • Hello Gabriel. THank you for your answer. I tried following your steps, but QGIS does not allow me to export the data. To be sure, when you at first upload the data, is it projected onto the map at all? Because my data is not, it is in table form. Regards Oliver
    – Oliver
    Feb 27 '20 at 11:12
  • 1
    I think that the coordinates are geographic instead of UTM zone 41N. In that case, the CRS must be EPSG:4258. The first axis is latitude and the second one is longitude. Maybe the x coordinate corresponds to longitudes, just check that with the geographic location of the points. Feb 27 '20 at 11:29
  • @GabrielDeLuca I thought so too, but using ETRS89 for the CRS does not work either.
    – Oliver
    Feb 27 '20 at 12:24
  • 1
    @Oliver I was going to comment that changing the decimal symbol might fix your issue, but I saw in your edit that it was indeed that. Glad to be of help! If the answer is acceptable, you can mark it as so, which will resolve the question in the system (unresolved questions are untidy!)
    – Gabriel
    Feb 27 '20 at 15:31
  • 1
    @GabrielDeLuca Yes, that was my mistake, I didn't enter the OP's CRS, I just used whatever my current data used at the time. I should have figured it might confuse him.
    – Gabriel
    Feb 27 '20 at 15:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.