2

When using the "TIN Interpolation" tool in QGIS 3.10, the output raster file doesn't keep the pixel size I specify. For example if I specify a pixel size of 1.0m, the output file actually has a pixel size around 0.99m. The pixels also aren't perfectly square sometimes. Has anyone else experienced this problem or discovered a solution?

I have pasted below example screenshots of two parameter values, and the properties of the output files I get.

Overall for this example I want to get an output raster with 500 rows and 100 columns, pixel size 1.0m. It's impossible to enter this in the parameters because when I change one value, another changes. e.g. when I enter a pixel size of 1.0m, the 'Rows' parameter updates to 500 and the 'Columns' parameter updates to 101. If I change the 'Columns' parameter to 100, the 'Rows' parameter automatically changes to 495 and the pixel size changes to 1.0101.

enter image description here

enter image description here

enter image description here

enter image description here

0
1

Had the same issue. Try exporting the TIN-ed layer and manually defining the extent, making sure that the North, East, South, and West values are divisible by the pixel size, in this case 5m

enter image description here

Then define the resolution as the required pixel size. Hopefully this does the trick.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.