0

I'm aware that this is the hundreth(possibly more) time someone asked about the distance matrix that is expressed in degrees, but should be in meters. I read most of the questions, online guides, etc., but there must be something I am doing wrong and I cannot figure out what. So here we go:

  1. I open a project in QGIS (3.4.15). I set the project CSR to "WGS 84 / UTM zone 32N", as I read that UTM is generally expressed in meters.
  2. I load two (csv) layers with an ID, longtitude and latitude data. One has specific events, the other with locations of households (of survey data). I load both with the same "WGS 84 / UTM zone 32N" csr.
  3. I check whether under "project properties" the right CSR is really set (WGS 84 / UTM zone 32N) and if distance measurements are set to meters. All is correct.

Then I run the distance matrix, but the units are expressed as degrees. I also tried loading the layers with another CSR (WGS84+GRS80 / Mercator) and reprojecting them to the UTM csr, and using the new reprojected layers to calculate the distance matrix. Again, degrees.

Would someone have advice or insight as to what I'm doing wrong? Any help is greatly appreciated as creating the matrix takes 45-50 mins (large layers) and I spend 1.5 days on this already.

1

When you import the CSV files with latitude and longitude in them - I'm assuming that means values like 51,2 (or other "small" values) - you commit the cardinal sin of lying to QGis about their projection. QGis is very trusting and believes you when you say these values are in metres measured from some distant origin. Thus you get incorrectly placed data (somewhere very close to that origin) and wrong distances.

So when you import the data you have to accept that it is stored in degrees and admit this to QGis. You then need to reproject the data to a projection that is in metres. If you are sure you live in UTM32N then that is a good choice, to reproject your data you select the layer and export the layer to a new file (geopackage is a good choice here) with the new CRS you need (EPSG:32632) - QGis will then add this new file to your project as a new layer. This layer will be in metres and you can proceed accordingly.

| improve this answer | |
  • Exporting the layer after reprojecting the data was the missing step! It worked now. Thank you so much! – Niicole16 Feb 27 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.