0

Hey I'm having problems installing the dataplotly plugin from the official repository.

Konnte Erweiterung 'DataPlotly' nicht laden 

ModuleNotFoundError: No module named 'plotly' 
Traceback (most recent call last):
  File "/app/share/qgis/python/qgis/utils.py", line 312, in loadPlugin
    __import__(packageName)
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/basti/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/__init__.py", line 25, in 
    from .data_plotly import DataPlotly
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/basti/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/data_plotly.py", line 31, in 
    from DataPlotly.gui.dock import DataPlotlyDock
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/basti/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/gui/dock.py", line 14, in 
    from DataPlotly.gui.plot_settings_widget import DataPlotlyPanelWidget
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/basti/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/gui/plot_settings_widget.py", line 74, in 
    from DataPlotly.core.plot_factory import PlotFactory
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/basti/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/core/plot_factory.py", line 14, in 
    import plotly
  File "/app/share/qgis/python/qgis/utils.py", line 744, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ModuleNotFoundError: No module named 'plotly'


Python-Version: 3.7.3 (default, Nov 10 2011, 15:00:00) [GCC 8.3.0] 
QGIS-Version: 3.10.3-A Coruña A Coruña, 0e1f8464 

Python-Pfad:
/app/share/qgis/python
/home/basto/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python
/plugins
/app/share/qgis/python/plugins
/usr/lib/python37.zip
/usr/lib/python3.7
/usr/lib/python3.7/lib-dynload
/usr/lib/python3.7/site-packages
/app/lib/python3.7/site-packages
/app/lib/python3.7/site-packages/numpy-1.14.3-py3.7-linux-x86_64.egg
/app/lib/python3.7/site-packages/MarkupSafe-1.0-py3.7-linux-x86_64.egg

I installed plotly without errors and with these commands:

pip install plotly 
pip3 install plotly

Didn't had the problem on my Manjaro-Gnome machine. Guess it depends on some python path (environment variable), but can't find anything.

Can I set the path where QGIS is searching for the python-libs?

  • I'm running Mint 19.3 and QGIS 3.10 and have installed the plugin from the repository without issue... didn't have to install plotly from terminal or anything... working just fine. Not sure why you can't install from the plugins repository - nothing in that error message stands out to me... – DPSSpatial Feb 27 at 17:36
  • Interesting. thank you for the comment, cause even on my Manjaro-machine it just started working after I installed plotly by ´pip install plotly´ – basto Feb 27 at 17:40
0

I'm able to install the Dataplotly plugin on Linux Mint now. I realized that I installed the qgis-flatpack version some time ago.

So I uninstalled the flatpack, installed from the official repos and now it works like a charm.

Lesson learned:
I'll never use flatpack again!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.