1

I've created a survey in Survey123 Connect, published it to ArcGIS online and am attempting to connect to the feature server to view the collected survey data in QGIS 3.10.2. To add the feature service I'm using Layer, Add Layer, Add ArcGIS FeatureService Layer.

The feature service link is posted below the following error:

Failed to retrieve service capabilities: Error 499: Token Required

https://services8.arcgis.com/8tX9OH8doNBidChm/ArcGIS/rest/services/service_edbe38394aa44de28045d39f27ffaecc/FeatureServer/0?token=YyrjuSR45GWMoH0A0WIifewkW_LAiYvu1OVr1HXJLNJSRO9Lphb48Jr8fxjofTEeRf3UPMoIIHJVIe-DSpp6vuNVlaB_GzvfykiA8Mm9autHVoWvZjWKI1W0uKhcV2lwiSoPQCKG42KtKKz0lc2ZyjAxVti8WJPhYvhKxAR-wrgOPOoXc17xEwfXo8bPN3nijUVnP83459I3D9GKSe79j3L3gYwPRHM_ONO-BtJCCQlAPwiqS9R1OOKeclbJzcMV

To establish the connection I've only used the following portion of the URL: https://services8.arcgis.com/8tX9OH8doNBidChm/ArcGIS/rest/services/service_edbe38394aa44de28045d39f27ffaecc/FeatureServer/

I've added the same feature layer in ArcMap 10.5 with no issues (using add data from ArcGIS online).

I've tested another survey feature service layer that I built in Survey123 Connect under a different ESRI username and organization and it loads with no issues in the same QGIS project: https://services2.arcgis.com/NlsizNmbMFiinWw4/ArcGIS/rest/services/service_0ca13752c9fb461f9b1d1b2490f79504/FeatureServer/

If you have any ideas I'd love to hear them.

0

Update: I discovered that I first needed to set the share level to 'Everyone (public) before the feature layer could be accessed. This can be done under Content in the ArcGIS online account. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.