0

At 10.7.1, I have created this very simple model:

enter image description here

However, when I run the model, it immediately fails at the Add Field tool, with this response:

Executing (Add Field): AddField C:\WorkSpace\CDLT\PARCEL_MODEL\Parcels.shp cdlt_acres DOUBLE # 2 # # NULLABLE NON_REQUIRED #
Start Time: Tue Mar 3 16:09:08 2020
Adding cdlt_acres to C:\WorkSpace\CDLT\PARCEL_MODEL\Parcels.shp...
ERROR 999999: Error executing function.
Failed to execute (Add Field).

Unfortunately, there is no help for ERROR 999999, so I turn to SE for assistance. I've checked the shapefile's geometry, and restarted Arc, but the error still persists.

FWIW, here are the contents of the model's Add Field tool:

enter image description here

  • 3
    Does the Add Field work if you run it as a stand-alone tool (outside of the model)? How about if you use a different field name? Field type? Empty field scale? Run it against a new copy of the shapefile? – Son of a Beach Mar 4 at 0:38
  • @SonofaBeach All good questions, I will edit accordingly – Stu Smith Mar 4 at 1:05
  • 1
    Do you have write access to the location where the shapefile exists? – Fezter Mar 4 at 1:31
  • 2
    dBase does not support numeric NULL values, and might require more width details (since it stores floating-point vales as text). It might just be time to abandon shapefile entirely (I did, eight years ago). – Vince Mar 4 at 1:50
  • @Vince I agree about abandoning shapefiles (Hello Geopackage!). This situation, however, was for a client that uses them. – Stu Smith Mar 5 at 0:28
1

I would work on a process of elimination as follows.

Does the Add Field work if you run it...

  • as a stand-alone tool (outside of the model)?
  • with a different field name?
  • different field type?
  • different field scale?
  • with a new copy of the shapefile?
  • including a field precision?

(This last/bold one added after your comment that it actually solved the problem. This may also be related @Vince comment about requiring more width details in dBase/shapefile data. It's a shame we still have to use Shapefiles from time to time to support some users/clients! fGDBs are also not ideal, but somewhat better than Shapefiles.)

| improve this answer | |
0

The error might because of because of null geometry. Try repairing the geometry, if it work you could integrate this to your model.

ESRI data management tools

| improve this answer | |
  • Thanks, @NPaudel. As I mentioned in the OP, the geometry checked ok. – Stu Smith Mar 5 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.