4

I'd like to use a MongoDB database from GeoServer. There seems to be a GeoTools plug-in available (http://repo.opengeo.org/org/geotools/gt-mongodb/), and I've dropped the latest version (8.2) into the webapps\geoserver\WEB-INF\lib folder and restarted, but it doesn't show up in the new data source list within Geoserver.

Any ideas?

I'm using GeoServer 2.2 on Windows 7 64-bit.

2
  • What is the exact path and exact .jar file that you used to make the plugin work? There are 2 .jar s in this repo: repo.opengeo.org/org/geotools/gt-mongodb/8.7 I'ld guess I should use the "gt-mongodb-8.7.jar" one, but I'm not sure that I'm right and that I know on what folder I should add it. Can you help me?
    – user16299
    Mar 18, 2013 at 23:03
  • Yes, it's gt-mongodb-8.7.jar - the other one contains the source code for the plug-in. Mar 25, 2013 at 8:16

1 Answer 1

6

Solved the issue myself (as always, I figured it out just after posting). The MongoDB Driver JAR needs to be placed in the classpath (same folder worked for me) as well.

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.