1

I'm trying to install QGis Server 3.4 on Windows. Apache says "500 Internal Server error" and if I execute qgis_mapserv.fcgi.exe, I get this:

enter image description here

(something along the way "can't find entry point for procedure foo in dll bar")

I installed it via OSGeo4W, selecting Desktop->qgis-ltr v3.10.3-1 (which fires up nicely), Libs->fcgi v2.4.1-2, and Web->qgis-ltr-server v3.4.15-1

In case it's some use, here's my PATH: C:\OSGeo4W64\bin;C:\OSGeo4W64\apps\qgis-ltr\bin;C:\OSGeo4W64\apps\grass\grass78\lib;C:\OSGeo4W64\apps\grass\grass78\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\WBem;c:\OSGeo4W64\apps\qt5\bin. Those grass references are about and old QGis Server 2.18 installation, which I totally wiped.

1
  • Execute from the command line. Anyway, I solved it. I'll edit the question
    – faibistes
    Mar 5 '20 at 7:23
2

I finally managed to get it working. qgis server and qgis desktop versions must match. I wanted the server to be v3.4, but AFAIK it can't be done, so I installed qgis-ltr-server v3.10.3-1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.