0

I am trying to follow the instructions for how to enable time dimension to image mosaic in GeoServer:

https://docs.geoserver.org/latest/en/user/tutorials/imagemosaic_timeseries/imagemosaic_timeseries.html

I added several times the data source but when I add the layer time dimension is not available.

I didn't find how to do this:

To support time-series layers, GeoServer needs to be run in a web container that has the timezone properly configured. To set the time zone to be Coordinated Universal Time (UTC), add this switch when launching the java process:

-Duser.timezone=GMT If using a shapefile as the mosaic index store (see next section), another java process option is needed to enable support for timestamps in shapefile stores:

-Dorg.geotools.shapefile.datetime=true

This is an example of my image names: T30SYJ_20190918T105029_10m_RGB.tif

And the code in indexer.properties:

Schema=*the_geom:Polygon,location:String,ingestion:java.util.Date,elevation:Double
PropertyCollectors=TimestampFileNameExtractorSPI[timeregex](ingestion)
TimeAttribute=ingestion
Caching=false
AbsolutePath=false

And the code in timeregex.properties:

regex=[0-9]{8}T[0-9]{9}Z(\?!.\*[0-9]{8}T[0-9]{9}Z.\*)
1

Your regexp must match the time/date part of your image names, so given:

T30SYJ_20190918T105029_10m_RGB.tif

you need to match 8 digits a T and 6 digits so

regex=[0-9]{8}T[0-9]{6}

should work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.